Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 06, 2025 - 23:00 NZDT
Scheduled
We are repairing a section of fibre in the Tauranga area. A number of services will have an outage of up to 2 hours between 23:00 Thursday 6th of March and 06:00 on Friday 7th of March . We apologise for any inconvenience this may cause. If you have any issues with your service(s) after this change window ends, please get in touch with your broadband service provider.
Posted Feb 28, 2025 - 07:53 NZDT
This scheduled maintenance affected: Bay of Plenty Fibre Network (Tauranga Fibre Network).