Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Nov 20, 2025 - 00:00 NZDT
Scheduled
Planned upgrade is being carried out on the core fibre network to Whanganui. This will result in a service outage affecting all Mercury customers in Whanganui for up to 15 minutes between 00:00 - 06:00 on Thursday, 20th November 2025. We apologise for any inconvenience this may cause.
Posted Nov 18, 2025 - 08:34 NZDT
This scheduled maintenance affected: Manawatu-Whanganui Fibre Network (Whanganui Fibre Network).