Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Nov 14, 2024 - 10:00 NZDT
Scheduled
We are performing a network upgrade in Hamilton, affecting all of the Hamilton region. A large number of services will have an outage of up to 30 minutes between Thursday 14th of November 10:00 - 15:00 Thursday 14th of November. We apologise for any inconvenience this may cause. If you have any issues with your service(s) after this change window ends, please get in touch with your broadband service provider.
Posted Nov 07, 2024 - 11:10 NZDT
This scheduled maintenance affected: Waikato Fibre Network (Hamilton Fibre Network).