Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Aug 20, 2025 - 22:00 NZST
Scheduled
We are performing maintenance activities on our core fibre network in Tauranga. All services in the Omokoroa and Katikati area will incur an outage of up to 1 hour between 22:00 Wednesday, 20th August 2025, and 06:00 Thursday, 21st August 2025. We apologise for any inconvenience this may cause. If you have any issues with your service(s) after this change window ends, please get in touch with your broadband service provider.
Posted Aug 18, 2025 - 08:18 NZST
This scheduled maintenance affected: Bay of Plenty Fibre Network (Katikati Fibre Network, Omokoroa Fibre Network).