Network Outage in Hamilton

Resolved

This incident has been resolved.
Posted Jul 25, 2025 - 09:35 NZST

Investigating

We are currently investigating an issue affecting some customers in Hamilton without service.
Posted Jul 25, 2025 - 07:48 NZST
This incident affected: Waikato Fibre Network (Hamilton Fibre Network).