Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Dec 01, 2025 - 23:00 NZDT
Scheduled
Planned maintenance is being carried out on the core fibre network to Levin. This work will result in a service outage affecting all customers in Levin for up to 5 hours between 23:00 Monday, 1 December and 06:00 Tuesday, 2 December 2025.
We apologise for any inconvenience this may cause. If you have any issues with your service(s) after this change window ends, please get in touch with your broadband service provider.
Posted Nov 28, 2025 - 11:08 NZDT
This scheduled maintenance affected: Manawatu-Whanganui Fibre Network (Levin Fibre Network).