Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 27, 2025 - 23:00 NZDT
Scheduled
We are performing maintenance activities on our core fibre network between Hamilton and Milldale. All services in the Milldale area will incur an outage of up to 30-minute between 23:00 Thursday 27th March 2025 and 06:00 28th Friday March 2025. We apologise for any inconvenience this may cause. If you have any issues with your service(s) after this change window ends, please get in touch with your broadband service provider.
Posted Mar 24, 2025 - 09:40 NZDT
This scheduled maintenance affected: Auckland Fibre Network (Milldale Fibre Network).